Upgrade di MySql e downtime

settembre 16, 2010
By

Su Gentoo (ma anche sulle altre distro a quanto vedo sai forum) l’upgrade a mysql 5.1 dalla 5.0 causa un bel downtime non richiesto
Manca la libreria libmysqlclient.so.15 sostituita dalla libmysqlclient.so.16
Questo causa il mancato riavvio di tutto quello che può voler usare mysql: dovecot, apache (tramite php o mod_auth vari) …
Su Gentoo la soluzione è un revdep-rebuild che porta alla ricompilazione di php, apr-utils, dovecot, postfix, DBD-mysql … (nel mio caso)

E con questa sono due le volte che mi arriva del downtime a causa dell’upgrade di una minor version (l’altra è stata il passaggio a apache 2.2, con l’esplosione del httpd.conf )

Tags: , , , ,

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *


*